DASH, BCH and BCHA transactions are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 12:04 UTC
Investigating
We are currently investigating this issue.
Posted Jun 04, 2021 - 08:21 UTC
This incident affected: Crypto Deposits (BCH, DASH, BCHA) and Crypto Withdrawals (BCH, DASH, BCHA).