CEX.IO maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 03, 2024 - 10:30 UTC
Monitoring
We are currently experiencing some technical issues causing disruptions to a few of our services like Wallet, Prime and Spot Trading. Our team is actively working to resolve these problems as quickly as possible.

During this time, customers may experience troubles with access to these services and making transactions.

We sincerely apologize for any inconvenience this may cause. Rest assured we are making every effort to restore full functionality soon. We will provide an update once the issues have been resolved.

Thank you for your patience and understanding.
Posted May 02, 2024 - 08:37 UTC