CEX.IO Exchange Trade maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 11:07 UTC
Investigating
We are currently investigating this issue.
Posted Jul 29, 2022 - 10:49 UTC
This incident affected: Uptime (Trade Page).