Degraded Performance – Customer Support

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 12:06 UTC

Identified

We are currently experiencing degraded performance in our Customer Support systems due to an ongoing AWS outage affecting some of our infrastructure.
Posted Oct 20, 2025 - 12:02 UTC
This incident affected: Uptime (Customer Support).