DOGE transactions are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 06:59 UTC
Investigating
We are currently investigating this issue.
Posted Nov 17, 2021 - 12:16 UTC
This incident affected: Crypto Deposits (DOGE) and Crypto Withdrawals (DOGE).