Blog under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 13, 2019 - 12:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Mar 13, 2019 - 11:37 UTC