Spot Trading Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 14:06 UTC
Investigating
We are currently investigating this issue.
Posted Mar 20, 2024 - 13:22 UTC
This incident affected: CEX.IO Spot Trading (Trading).