BCH deposits, LTC and DASH deposits and withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 16:21 UTC
Update
We are continuing to investigate this issue.
Posted Feb 22, 2021 - 15:44 UTC
Update
We are continuing to investigate this issue.
Posted Feb 22, 2021 - 15:44 UTC
Investigating
We are currently investigating this issue.
Posted Feb 22, 2021 - 15:42 UTC
This incident affected: Crypto Deposits (LTC, BCH, DASH) and Crypto Withdrawals (LTC, DASH).