CEX.IO maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:18 UTC
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 07:17 UTC
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 07:16 UTC
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 06:57 UTC
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 06:53 UTC
Investigating
We are currently investigating this issue.
Posted Jun 21, 2022 - 06:48 UTC
This incident affected: Uptime (Website availability) and Mobile Application.