ETH transactions unstable.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Sep 14, 2018 - 14:35 UTC
Identified
ETA - 1h
Posted Sep 14, 2018 - 13:39 UTC
Investigating
ETH transactions unstable. We are now working on this issue
Posted Sep 14, 2018 - 13:36 UTC
This incident affected: Crypto Deposits (ETH).