LTC withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 19:15 UTC
Investigating
We are currently investigating this issue.
Posted Nov 25, 2022 - 06:09 UTC
This incident affected: Crypto Withdrawals (LTC).