SOL withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 07:05 UTC
Update
We are continuing to investigate this issue.
Posted Apr 05, 2024 - 07:05 UTC
Investigating
We are currently investigating this issue.
Posted Apr 05, 2024 - 05:45 UTC
This incident affected: Crypto Withdrawals (SOL).