BTC withdrawals under unscheduled maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 28, 2019 - 14:26 UTC
Identified
The issue has been identified and fix is being implemented. ETA - 1 hour
Posted Jan 28, 2019 - 13:31 UTC
Investigating
We are currently investigating this issue.
Posted Jan 28, 2019 - 12:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 17, 2019 - 18:39 UTC
Investigating
We are currently investigating this issue.
Posted Jan 04, 2019 - 20:35 UTC
This incident affected: Crypto Deposits (LTC).