ETH deposits via Smart contracts maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 08, 2022 - 10:04 UTC
Investigating
We are currently investigating this issue.
Posted Jan 17, 2022 - 16:02 UTC
This incident affected: Crypto Deposits (ETH).