LTC, BSV operations under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 21, 2019 - 17:21 UTC
Update
LTC operations are fully restored. We are working on a fix for BSV
Posted 3 months ago. Mar 21, 2019 - 15:00 UTC
Monitoring
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Mar 19, 2019 - 00:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Mar 18, 2019 - 18:58 UTC
This incident affected: Crypto Deposits (LTC, ETH).