Service Interruptions
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 29, 2018 - 15:24 UTC
Identified
The issue has been identified and the fix is being implemented. Deposit/Withdrawal service might be affected.
Posted Nov 29, 2018 - 14:07 UTC
This incident affected: Uptime (Website availability).