ETH withdrawals unstable
Incident Report for CEX.IO
Resolved
Issue re-solved
Posted Sep 18, 2018 - 09:50 UTC
Investigating
We are currently investigating this issue.
Posted Sep 17, 2018 - 20:03 UTC
This incident affected: Crypto Deposits (LTC).