KNC deposits are under maintenance.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 09:51 UTC
Investigating
We are currently investigating this issue.
Posted May 30, 2021 - 08:44 UTC
This incident affected: Crypto Deposits (KNC).