MHC withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 26, 2020 - 21:02 UTC
Investigating
We are currently investigating this issue.
Posted Nov 26, 2020 - 20:33 UTC
This incident affected: Crypto Withdrawals (MHC).