ETH transactions are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 00:32 UTC
Investigating
We are currently investigating this issue.
Posted Apr 29, 2021 - 12:45 UTC
This incident affected: Crypto Withdrawals (ETH) and Crypto Deposits (ETH).