Congestion in processing BTC withdrawals
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 12, 2022 - 13:54 UTC
Investigating
We are currently investigating this issue.
Posted May 12, 2022 - 10:15 UTC
This incident affected: Crypto Withdrawals (BTC).