USDT withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 11, 2021 - 18:40 UTC
Investigating
We are currently investigating this issue.
Posted Jan 11, 2021 - 16:57 UTC
This incident affected: Crypto Withdrawals (USDT).