ATOM withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 02:21 UTC
Update
We are continuing to investigate this issue.
Posted Oct 12, 2021 - 20:09 UTC
Investigating
We are currently investigating this issue.
Posted Oct 12, 2021 - 20:07 UTC
This incident affected: Crypto Withdrawals (ATOM).