XLM transactions are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 10:57 UTC
Investigating
We are currently investigating this issue.
Posted Jun 03, 2021 - 09:54 UTC
This incident affected: Crypto Deposits (XLM) and Crypto Withdrawals (XLM).