ETH withdrawals and deposits under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 11, 2019 - 14:15 UTC
Update
ETH deposits and withdrawals are not available for 32 hours.
Posted about 1 month ago. Mar 11, 2019 - 12:40 UTC
Update
We are continuing to work on a fix for this issue.
Posted about 1 month ago. Mar 08, 2019 - 18:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Mar 08, 2019 - 16:07 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.