LAMB withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Mar 06, 2021 - 10:03 UTC
Investigating
We are currently investigating this issue.
Posted Mar 04, 2021 - 15:28 UTC
This incident affected: Crypto Withdrawals (LAMB).