ETH Transactions Temporarily Unavailable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 18, 2019 - 11:33 UTC
Investigating
We are currently investigating this issue.
Posted Apr 17, 2019 - 07:17 UTC
This incident affected: Crypto Deposits (LTC, ETH).