GUSD withdrawal maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 15:27 UTC
Investigating
We are currently investigating this issue.
Posted Jun 20, 2022 - 07:32 UTC
This incident affected: Crypto Withdrawals (GUSD).