ENJ (Enjin Coin) deposits maintenance

Incident Report for CEX.IO

Resolved

ENJ will be available in a “trade only” option due to the liquidity provider’s possibilities. The transfer process will take several working days.
Posted Mar 26, 2026 - 16:47 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 01, 2025 - 11:52 UTC