ATOM withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 08, 2021 - 13:42 UTC
Investigating
We are currently investigating this issue.
Posted Apr 08, 2021 - 12:37 UTC
This incident affected: Crypto Withdrawals (ATOM).