CEX.IO and Mobile app unavailable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 24, 2019 - 12:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 24, 2019 - 11:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 24, 2019 - 11:46 UTC
This incident affected: Uptime (Website availability).