ETH transactions are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 02, 2021 - 11:09 UTC
Investigating
We are currently investigating this issue.
Posted May 02, 2021 - 08:31 UTC
This incident affected: Crypto Withdrawals (ETH) and Crypto Deposits (ETH).