LUNA2 deposits maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 24, 2023 - 12:24 UTC
Update
We are continuing to investigate this issue.
Posted May 16, 2023 - 07:06 UTC
Investigating
We are currently investigating this issue.
Posted Dec 29, 2022 - 20:02 UTC
This incident affected: Crypto Deposits (LUNA2) and Crypto Withdrawals (LUNA2).