ATOM transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 06:55 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 16, 2020 - 09:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 16, 2020 - 09:30 UTC
This incident affected: Crypto Withdrawals (ADA, ATOM) and Crypto Deposits (ADA, ATOM).