Platform Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 11:17 UTC
Investigating
Dear customers,
We regret to inform you that our platform will be undergoing maintenance due to a technical issue. This maintenance is essential to resolve the problem and restore full functionality to our services.

During this maintenance period, our platform may experience intermittent downtime or limited functionality. We apologize for the inconvenience and disruption this may cause. Our technical team is working diligently to resolve the issue as quickly as possible.

We understand the importance of our platform to your operations and deeply value your patience and understanding during this situation.
For the latest updates on the maintenance progress, please monitor our status page at https://status.cex.io/
Posted Mar 12, 2024 - 10:49 UTC
This incident affected: Uptime (Website availability).