XLM deposits are unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 04, 2020 - 06:58 UTC
Investigating
ETA was postponed indefinitely
Posted Apr 03, 2020 - 20:20 UTC
This incident affected: Crypto Deposits (XLM).