ADA withdrawals and deposits are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 16, 2020 - 23:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2020 - 22:33 UTC
This incident affected: Crypto Withdrawals (ADA) and Crypto Deposits (ADA).