MHC withdrawals and deposits are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 19:29 UTC
Investigating
We are currently investigating this issue.
Posted Jul 19, 2021 - 14:47 UTC
This incident affected: Crypto Withdrawals (MHC) and Crypto Deposits (MHC).