Crypto deposits and withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 10:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 10:00 UTC
Identified
Crypto deposits and withdrawals are currently undergoing maintenance. We are working on implementing improvements. The estimated time for completion is 30 minutes.
Posted Apr 08, 2024 - 09:37 UTC
This incident affected: CEX.IO Wallet.