CEX.IO BROKER under maintenance
Incident Report for CEX.IO
Resolved
We are happy to inform you that maintenance is over.
Posted Jul 15, 2019 - 04:58 UTC
Identified
Trading terminal may be unstable due to the maintenance. Please accept our apologies for such inconveniences.
Posted Jul 15, 2019 - 04:09 UTC