BTC Withdrawals unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 15, 2019 - 11:19 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Mar 15, 2019 - 07:17 UTC
This incident affected: Crypto Withdrawals.