DOGS, HMSTR, and NOT withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 08:49 UTC
Investigating
We are currently investigating this issue.
Posted Oct 30, 2024 - 15:43 UTC
This incident affected: Crypto Withdrawals (DOGS, HMSTR, NOT).