CEX.IO Broker trading terminal under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 26, 2019 - 05:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 26, 2019 - 05:15 UTC