ETH deposits and withdrawals unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Sep 17, 2018 - 13:25 UTC
Identified
We are now working on this issue. ETA - 3 hours
Posted Sep 17, 2018 - 10:36 UTC
This incident affected: Crypto Deposits (LTC, ETH).