Ethereum network transactions maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 09:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 20, 2025 - 08:24 UTC
This incident affected: Crypto Withdrawals (ERC-20 tokens) and Crypto Deposits (ERC-20 tokens).