XRP withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 28, 2021 - 16:04 UTC
Investigating
We are currently investigating this issue.
Posted Nov 28, 2021 - 12:12 UTC
This incident affected: Crypto Withdrawals (XRP).