BTC withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 05:10 UTC
Investigating
We are currently investigating this issue.
Posted Jul 26, 2022 - 19:16 UTC
This incident affected: Crypto Withdrawals (BTC).