GAS withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 10:48 UTC
Investigating
We are currently investigating this issue.
Posted Dec 23, 2020 - 12:11 UTC
This incident affected: Crypto Withdrawals (GAS).