BEL, BNB, CAKE, XVS withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 23:01 UTC
Investigating
We are currently investigating this issue.
Posted Oct 14, 2021 - 19:55 UTC
This incident affected: Crypto Withdrawals (BNB, BEL, CAKE, XVS).