ETH withdrawals under unexpected maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 20, 2019 - 22:12 UTC
Investigating
We are currently investigating this issue.
Posted May 20, 2019 - 21:35 UTC
This incident affected: Crypto Deposits (LTC).